ios

Uygulamanın desteklediği minimum iOS versiyonu ne olmalı?

Bir mobil projeye başlamadan önce mutlaka destekleyeceğiniz minimum versiyonlu işletim sistemlerini seçmelisiniz. Buna karar verirken de mutlaka hedef kitlenizin kullandığı işletim sistemi versiyonlarını ile kullanım yüzdelerini araştırmalı ve maliyet-getirisine bakıp desteklenecek minimum versiyona karar vermelisiniz.

Apple’in yayınladığı istatistikler bize son iki yılda yayınlanan sürümlerin %95 kullanım oranına sahip olduğunu söylüyor. Bu yazının yazıldığı tarihte (11.01.2017) iOS 10.x ve iOS 9.x ‘in toplam kullanım yüzdesi %94’ü geçmişti.

Aktif olarak cihazına uygulama indirip kullanan kullanıcıların işletim sistemlerini inceleyerek konuyu derinleştirmekte yarar var. Bunun için de mixpanel‘in yayınladığı istatistiklere bakalım. Yine bu yazının yazıldığı tarihteki istatistiklere bakarsak, aktif olarak uygulama kullanan kullanıcıların %97’den fazlası iOS 10.x ve iOS 9.x kullanıyor. Yani iOS 9.x ‘den eski versiyonda işletim sistemine sahip kullanıcıların yaklaşık yarısı uygulama indirip kullanmıyor.

Bu rakamların bize söylediğini özetlersek, hedef kitlenizin yaklaşık %3 ‘ü, son iki major iOS versiyonundan eski bir versiyonda bir işletim sistemi kullanıyor. Benim naçizane tavsiyem bu %3’lük kesim için ekstra bir emek harcamanızın gereksiz olduğu. Unutmayın desteklemediğiniz versiyonları kullanan kullanıcıların oranı günbegün azalmaya devam edecek.

Uygulamanızı güncellerken de güncel istatistikleri incelemenizde fayda var. Bugün iOS 9.x ‘i destekleyen bir uygulamanın 1 yıl sonra iOS 9.x desteğini çekmesi hiç de mantıksız olmayacaktır.

Bir sonraki yazımızda aynı konuyu Android işletim sistemleri için tartışacağız.

Etiketler:
İstanbul Teknik Üniversitesi Bilgisayar Mühendisliği ve Marmara Üniversitesi MBA mezunu. 10 yılı aşkın süredir yazılım dünyasının içerisinde. Şu aralar mobil uygulamalar üzerinde çalışıyor ve Nişantaşı Üniversitesinde ders veriyor.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir